1997 Yukon 4wd - 4wd won't engage.

[ Follow Ups ] [ Post Followup ] [ OurSUV.com ]

Posted by steve ( on 13:27:02 10/19/11

Hi guys - Last weekend my 1997 Yukon 4wd failed to engage when the button on the dash was depressed. I was moving at the time, and it had worked in the morning just fine. I didn't watch the indicator light (it was flashing) and proceeded into some soft sand. Yep I stuck it good... Got out and noticed that front wheels weren't buried. Got back in and tried to rock it a bit, and my buddy noticed that the front wheels weren't spinning, only the back. Then I noticed that the 4wd indicator light was flashing not on solid. Luckily I carry a shovel, and radioed my other friend who we were out hunting with, and he yanked me out. So I checked the electrical connections underneath and all seemed fine, Where do I go from here? Don't have the $ to drop off @ dealer or shop. A friend said there's some sort of 'Modulator' that works with the front axle - Ok thanks in advance for any insight...

Follow Ups:

Post a Followup

Optional Link URL:
Link Title:
Optional Image URL:

[ Follow Ups ] [ Post Followup ] [ OurSUV.com ]

Contact us         Home Page
? 2007 Copyright. All Rights Reserved